0.7.0.post1 excludes TensorBoard version 2.3.0 and above when installing Guild AI. TensorBoard 2.3.0 contains a number of breaking changes to APIs that Guild uses.
These API incompatibilities are fixed in 0.7.1.
If you have TensorBoard 2.3.0 or later installed, downgrade to an earlier version for use with Guild.
pip install 'tensorboard<2.3'