Installation problems

I have reopened the issue on GitHub. I am not sure if you see it, so I just wanted to forward the link hereČ

For some reason, I canćt install guildai on windows, after reinstalling anaconda, but I was able to install it before.

Before update, I was able to install it.

I updated the GitHub issue with a comment. Your conda env is using Python 3.8 and prebuilt wheels aren’t yet available for Guild for that version. When you create your conda env, if you specify Python 3.6 or 3.7 you should be able to install Guild without issue.


Thanks for explanation.

Do you know when will approximately be available for python 3.8?

I’ll try to get this released this week. I’ll keep you posted!

Great. Thanks!

You should be able to install now for Python 3.8 on Windows using the pre-release version:

pip install --pre guildai

This will be generally available when 0.7.1 is released.

I have installed it successfully. It has some version conflicts with tensorflow 2.3, but it works.


What version conflicts are you seeing?

It was because of the tensorboard 2.3, if I remember right.

0.7.1.dev2 should work fine with TB 2.3. If you’re seeing issues, please let us know and we’ll get them resolved ASAP. Thanks!

It didn’t get eny error with pip install --pre guildai know. Thanks.

1 Like

@garrett, is it possible to upgrade requirement to scikit-learn>=0.19.1. Now it is:

IS there a problem with scikit-learn=0.23.0?

Hi @mislav - this is a temporary restriction for the pre-release. I expect to support the latest from scikit-learn. There are API related issues related to changes to numpy that I hope are resolved before 0.7.1 is released.

You can force an install of a particular version using pip install scikit-learn==VER.

I’m running tests on 0.20.4 now to see how that goes.

Still issues with 0.20.4. You can try forcing that version but you may end up with an error on optimization using any of the scikit-learn optimizers. I’m seeing ValueError: array must not contain infs or NaNs in our tests.

I don’t offhand know what the root cause is but the goal is to fix this for 0.7.1. If need be we’ll monkey-patch the upstream libraries.

I wanted to install it with scikit-learn 0.23, not 0.20? In the end I downgraded it to 0.22.2.post1.

Sorry - I meant 0.23.2 - this version is problematic.

I works for now. I will wait for new release. Maybe 0.23 will be supported.