Dependency mismatch between and tensorflow

I currently have tensorflow installed, When I try to install There is a dependency version conflict and pipenv is not able to resolve it. The version conflicting dependency is tensorboard.

sarat@sarat-pc:~/Codes/guild_start $ pipenv install guildai
Installing guildai...
Adding guildai to Pipfile's [packages]...
✔ Installation Succeeded 
Pipfile.lock (66d06e) out of date, updating to (085a73)...
Locking [dev-packages] dependencies...
Locking [packages] dependencies...
Building requirements...
Resolving dependencies...
✘ Locking Failed! 
[ResolutionFailure]:   File "/home/sarat/.local/lib/python3.8/site-packages/pipenv/", line 741, in _main
[ResolutionFailure]:       resolve_packages(pre, clear, verbose, system, write, requirements_dir, packages, dev)
[ResolutionFailure]:   File "/home/sarat/.local/lib/python3.8/site-packages/pipenv/", line 702, in resolve_packages
[ResolutionFailure]:       results, resolver = resolve(
[ResolutionFailure]:   File "/home/sarat/.local/lib/python3.8/site-packages/pipenv/", line 684, in resolve
[ResolutionFailure]:       return resolve_deps(
[ResolutionFailure]:   File "/home/sarat/.local/lib/python3.8/site-packages/pipenv/", line 1395, in resolve_deps
[ResolutionFailure]:       results, hashes, markers_lookup, resolver, skipped = actually_resolve_deps(
[ResolutionFailure]:   File "/home/sarat/.local/lib/python3.8/site-packages/pipenv/", line 1108, in actually_resolve_deps
[ResolutionFailure]:       resolver.resolve()
[ResolutionFailure]:   File "/home/sarat/.local/lib/python3.8/site-packages/pipenv/", line 833, in resolve
[ResolutionFailure]:       raise ResolutionFailure(message=str(e))
[pipenv.exceptions.ResolutionFailure]: Warning: Your dependencies could not be resolved. You likely have a mismatch in your sub-dependencies.
  First try clearing your dependency cache with $ pipenv lock --clear, then try the original command again.
 Alternatively, you can use $ pipenv install --skip-lock to bypass this mechanism, then run $ pipenv graph to inspect the situation.
  Hint: try $ pipenv lock --pre if it is a pre-release dependency.
ERROR: Could not find a version that matches tensorboard<2.3.0,>=2.0.0,~=2.4 (from tensorflow==2.4.0->-r /tmp/pipenvjhzpx270requirements/pipenv-2yv9nm20-constraints.txt (line 2))
Tried: 1.6.0, 1.7.0, 1.8.0, 1.9.0, 1.10.0, 1.11.0, 1.12.0, 1.12.1, 1.12.2, 1.13.0, 1.13.1, 1.14.0, 1.15.0, 2.0.0, 2.0.1, 2.0.2, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.4.0
Skipped pre-versions: 1.6.0rc0
There are incompatible versions in the resolved dependencies:
  tensorboard<2.3.0,>=2.0.0 (from guildai==0.7.1.post1->-r /tmp/pipenvjhzpx270requirements/pipenv-2yv9nm20-constraints.txt (line 3))
  tensorboard~=2.4 (from tensorflow==2.4.0->-r /tmp/pipenvjhzpx270requirements/pipenv-2yv9nm20-constraints.txt (line 2))

So pipenv is not able to find compatible tensorflow and versions.

What version of tensorflow does support?

Guild does support TB 2.4 but that’s available in 0.7.2. Good news is that will be released within a week. If you want you can use a pre-release version. Install it using:

pip install --upgrade --pre guildai

If that still gives you trouble please let us know and we’ll get it resolved ASAP. The latest TensorBoard is intended to be fully supported.

I have installed the pre-release version of guild-0.7.2 and there is no tensorboard version conflict.

pipenv install guildai==0.7.2rc1

Thanks for quick response.

1 Like